Attention : nouvelle adresse mail depuis novembre 2017. Ne plus utiliser l'ancienne hébergée chez Yahoo!

jeudi 14 juillet 2016

Un Alesis QS6 revient à la vie, mais avec de grosses séquelles : La Poste et le 100% médiocrité!

Quelques exercices d'assouplissement après pratiquement deux mois de travail intensif pour préparer les sujets que j'ai présenté au MakerFaire de Nantes ce week-end du 9-10 juillet. Je reviendrai sur cet évènement dans un prochain billet...

Quoi de mieux pour se détendre que d'entreprendre le sauvetage d'une machine sans intérêt, mais... à la signature sonore intéressante. Je viens d'acquérir ce QS6 au prix astronomique de 80€, frais de port compris, avec un gros problème de génération sonore.

le QS6 en image :

Image récupérée sur le Web.
Le symptôme est assez simple. L'appui d'une touche du clavier génère une espèce de séquence de divers instruments à diverses fréquences. J'ai simplement pressé une note aigüe et plus grave pendant environ 30s chaqu'une :



Intéressant n'est-ce pas?

Serait-ce le processeur de la machine qui perd les pédales?
Sans doute pas, le fonctionnement général du panneau de contrôle ne présente aucun problème.
Il convient alors d'étudier de près la carte électronique du synthé :


Rien de compliqué sur cette carte. Les différentes sections sont très faciles à identifier. A noter que la section 'génération sonore' comporte la batterie de ROM d'échantillons sur l'autre face, juste sous le connecteur de carte d'extension.

Récapitulatif :

  • La section effet fonctionne. Le rajout d'effet rajoute des effets, et c'est tout!
  • La partie processeur fonctionne. Je ne la met pas en cause.
  • La section de gestion des 'organes de commande' fonctionne aussi.
  • Et de toute façon si c'est le gros circuit avec sa pastille rouge qui est en cause, je ne pourrai rien faire de plus. Mais je ne pense pas. Les circuits de chez AMI sont 'forcément' fiables.

Ne reste donc plus que la génération sonore à tester. Les soudures de la banque de ROM ont déjà été refaites. Je ne mets de toute façon pas ces circuits en cause, le rendu sonore serait différent :

Belle couche de décapant!
Que reste-il à vérifier?

Et oui, un 'vulgaire' décodeur logique de type 138 en version AC, un 74AC138 de chez Fairchid :



Un rapide coup d'œil aux différents signaux confirme mes doutes :

Entrée E3

Au repos, la seule patte active de ce 138 est la patte n°6 nommée E3 :


Pour faire simple : toutes les sortie Y0 à Y7 sont à '1' quand AU MOINS une des entrées de sélection de ce circuit est INACTIVE. E1 et E2 sont câblés à '0', ces entrées sont actives. C'est alors E3, seul, qui sert de signal de validation des sorties. E3 est très majoritairement à '0' donc inactive, avec de très petits pics de sélection à une fréquence de 48KHz (voir image du signal au dessus).

En conséquence de quoi, je devrais avoir toutes les sorties à '1' sauf une d'entre elles qui devrait présenter le même genre de pic, mais vers le '0'. Les entrées à décoder A0 à A2 sont stables et à '0'. Il ne devrait donc y avoir que la sortie Y0 à changer d'état à une fréquence de 48KHz.

En réalité, toutes les sorties restent à '1' SAUF la sortie Y1 'scotchée' irrémédiablement à '0'. Or, les sorties de ce décodeur servent à sélectionner les ROM d'échantillon. Le doute n'est plus permis, je retire ce composant :


En tout les cas, cela confirme bien le fait que ce circuit 74AC138 sélectionne les ROM d'échantillons.

Ne reste plus qu'à le remplacer. J'ai retrouvé sans problème le même type de circuit chez Farnell au prix de 0,342€HT à l'unité (code commande : 2453170). J'en ai profité pour acquérir aussi d'autres composants, histoire de rentabiliser les frais de commande chez Farnell.

Une fois ce circuit remplacé, cela donne cici :


Forcément : c'est beaucoup mieux!

Que reste-il à faire sur cette machine?
En fait plus grand chose au niveau électronique. Nettoyer les traces précédentes d'intervention et remettre en place une pile de sauvegarde de 3V.

Le panneau de commande du synthé est en bon état, il ne requiert qu'un léger nettoyage.

LA POSTE :

Par contre j'en profite pour adresser un niveau 100% médiocrité à la poste. J'ai reçu très récemment un Alpha Juno2 en panne, lui aussi à prix très bas. Les angles de la caisse étaient bien abîmés. J'ai pu redresser le tout avec un résultat visuel très satisfaisant. Évidemment, sur ce genre de synthé, 'bas de gamme', la tôle de la caisse ne ressemble pas a celle d'une machine de chez Séquential, mais quand même... Pour ce QS6, j'ai eu droit à une partie du clavier explosée :

Joli travail La Poste!!!
J'ai bien noté aussi le petit commentaire du livreur : l'expéditeur à effectué un très bon emballage!
Ce qui pour moi raisonnait de suite comme grosse source de problèmes à venir, je n'ai pas été déçus!!!

LA POSTE : NE PRENEZ PAS EN CHARGE DES ENVOIS QUE VOUS N'ETES PAS CAPABLES DE GÉRER CORRECTEMENT!!!

Arguons qu'il s'agit certainement d'un problème de manque de personnel ou de chaîne de tri vétuste!!!
En sachant, évidemment, que les centres de tris actuels sont sur-équipés en matériels modernes et en personnels disons, hyper motivés et impliqués :


Je vais tenter une opération de sauvetage du clavier de ce QS6. Je verrai bien si ça aboutit. Toujours est-il que le générateur sonore fonctionne parfaitement, c'était quand même ça le 'jeu', à la base.

Le clavier est forcément difficilement utilisable, mais heureusement il reste la solution M.I.D.I.
Et maintenant que j'ai réalisé des convertisseurs me permettant la mise en place d'une liaison M.I.D.I. beaucoup plus pratique, je peux 'planquer' ce synthé un peu à l'écart...

Aucun commentaire:

Enregistrer un commentaire